I do not own FINAL FANTASY® XIV ONLINE STARTER EDITION. Do I need it to be able to play FINAL FANTASY® XIV: HEAVENSWARD™?

Yes, you are required to own FINAL FANTASY® XIV ONLINE STARTER EDITION to be able to play this expansion.




Powered by Zendesk